Jump to content


Reports Trial not working??


11 replies to this topic

#1 arnolde

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 30 June 2011 - 07:58 AM

Hi,

I activated the reports trial in the server admin tool yesterday, since then I've logged in and out, shutdown and restarted the client, and waited overnight, but still there are no reports available.
In the client, top left, next to my name, the "reports" dropdown contents are still all grey (day/month/year etc.)

Just checked the server admin again, it says "6 days remaining".

What am I doing wrong?

regards,
Ethan

#2 Derek Punzova

    Support Team Member

  • Moderators
  • 6181 posts

Posted 30 June 2011 - 10:12 AM

This will help:
http://www.livezilla.net/faq/en/#livezi ... -available
- If you like to suggest a new feature, please click here.
Kind Regards,
Derek

#3 arnolde

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 30 June 2011 - 10:28 AM

Hi,

sorry, doesnt really help.
I had already activated and enabled the reporting.

My stats directory permssions:

drwxrwxrwx  5 wwwrun  users 4096 2011-06-30 12:21 ./
drwxr-xr-x 16 arnolde users 4096 2011-06-30 12:21 ../
drwxrwxrwx  2 wwwrun  users 4096 2011-06-30 12:22 day/
-rwxrwxrwx  1 wwwrun  users   53 2011-06-26 15:53 .htaccess*
-rwxrwxrwx  1 wwwrun  users 1697 2011-06-25 15:42 index.html*
drwxrwxrwx  2 wwwrun  users 4096 2011-06-29 12:08 month/
drwxrwxrwx  2 wwwrun  users 4096 2011-06-29 12:08 year/
arnolde@eq4:/srv/www/vhosts/marketingclips/livesupport/stats>

When I point my browser to the stats directory, or day, or month etc., I get a 403 error and the apache log says:
client denied by server configuration: /srv/www/vhosts/marketingclips/livesupport/stats

I notice the .htaccess files in the stats directories all say:

        Order Allow,Deny
        Deny from All

Is that correct? How does the livezilla client download the stats if not via http, and how is that possible with these directives?

regards,
Ethan

#4 Derek Punzova

    Support Team Member

  • Moderators
  • 6181 posts

Posted 30 June 2011 - 11:25 AM

You are thinking in the wrong direction, there are other ways to download files (without directly accessing them). And I don't think that the download fails but the creation of the reports.

The FAQ entry also does contain some other things you will need to check:

Quote

If the suggestions listed above do not help, it may be necessary to readjust your PHP configuration. The value that should be increased is memory_limit. Depending on your host, this can be done in a number of places with the most likely being php.ini or .htaccess depending on your hosting situation. Add for example:

memory_limit = 196M to your php.ini file (recommended, if you have access)
With root access, you can use the sed util in Linux/Unix based systems, in order to increase the memory for 196M. Don't forget to properly locate your php.ini file! sed -i 's/memory_limit = .*/memory_limit = 196M/' /etc/php5/apache2/php.ini
ini_set('memory_limit', '196M'); to your sites/default/settings.php file
php_value memory_limit 196M to your .htaccess file in the LiveZilla root


If you are using an IIS webserver, please increase the Request & Activity Timeout value to at least 90 seconds. This page explains how to do that.

- If you like to suggest a new feature, please click here.
Kind Regards,
Derek

#5 arnolde

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 30 June 2011 - 11:32 AM

I'm not going to go messing around with global settings on my system without some funded evidence that it's necessary.
Please tell me how I can check if the memory limit (currently 128M) is really the problem.
There should be a logfile or debug setting somewhere to help in diagnostics.
I know my way around Linux and PHP pretty well so you can talk technical to me ;-)

#6 Derek Punzova

    Support Team Member

  • Moderators
  • 6181 posts

Posted 30 June 2011 - 11:48 AM

Quote

I know my way around Linux and PHP pretty well so you can talk technical to me
Great. So I am sure you will understand that the amount of memory needed only depends on the amount of visitors, chats, operators, browsers, events you have. There's no reasonable way to check if you PHP configuration is fine or not.

If you like to get this working, please try to increase the PHP memory limit. If this is not acceptable for you, please understand that there's nothing I can do for you.
- If you like to suggest a new feature, please click here.
Kind Regards,
Derek

#7 arnolde

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 30 June 2011 - 12:11 PM

Right, well there is one operator, about one visitor per hour and zero chats going on (on an average of the last week).
I expect the visitors to rise to about 10/hour (and maybe 1 chat/hour) in the next few days.
What can possibly need such a huge amount of memory???
(And mind you, I have lots of other stuff running just fine, gallery, shopsystem, etc. and THEY are all happy with 128M)

Anyway, I just followed the suggestion with the .htdocs in the livezilla root (15mins ago), and then I noticed some files in the stats/day directory:
-rw-r--r-- 1 wwwrun www 164111 2011-06-30 00:00 2011_06_29_7069c164685e
-rw-r--r-- 1 wwwrun www 46769 2011-06-30 00:00 2011_06_29_u_7069c164685e
But they seem to be dated at midnight and unchanged since. Does that make sense?
Should the "reports" dropdown in the chat client still be all grey? When will it "notice" that there is data to be read?

regards,
Ethan

#8 Derek Punzova

    Support Team Member

  • Moderators
  • 6181 posts

Posted 30 June 2011 - 01:14 PM

Ethan,

You should be fine with 128M when you have almost no visitors on your site (even 8M should be working in that situation).

The aggregation runs at midnight (finalizing the previous day) or when you use the "recalculate" function (right mouce click on one of the existing reports).
- If you like to suggest a new feature, please click here.
Kind Regards,
Derek

#9 arnolde

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 30 June 2011 - 01:15 PM

Even after changing the setting in php.ini to 196M, no change.
And yes, the change is active, i checked with phpinfo.

#10 arnolde

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 30 June 2011 - 01:22 PM

Oops, our posts crossed there.
Thanks for the more detailed estimate on the memory, i'll change it back now.

After reading your post, I went to "reports" in the bottom part of the window (where i had never been before) and thej i finally saw the tiny hint: "You dont have persmission to view/refresh reports". I am always logged in as a normal user operator, not as admin. Seeing that I went to the user rights editor and saw the tab "...has rights to see reports" and changed it and HEY PRESTO finally 2 reports came in.

Maybe you could add that hint to your FAQ, it might help other users.

regards,
Ethan

#11 Derek Punzova

    Support Team Member

  • Moderators
  • 6181 posts

Posted 30 June 2011 - 01:36 PM

You are right, thanks. I will add that information to the FAQ entry.
- If you like to suggest a new feature, please click here.
Kind Regards,
Derek

#12 arnolde

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 02 July 2011 - 04:06 PM

My server had some kind of problem last night, and after restarting it this morning around 11:00 CEST, it's not generating reports anymore.
The files in stats/day:
arnolde@eq4:/srv/www/vhosts/marketingclips/livesupport/stats/day> l
total 644
drwxrwxrwx 2 wwwrun users   4096 2011-07-02 12:25 ./
drwxrwxrwx 5 wwwrun users   4096 2011-06-30 12:21 ../
-rw-r--r-- 1 wwwrun www   164111 2011-06-30 00:00 2011_06_29_7069c164685e
-rw-r--r-- 1 wwwrun www    46769 2011-06-30 00:00 2011_06_29_u_7069c164685e
-rw-r--r-- 1 wwwrun www   129035 2011-07-01 00:00 2011_06_30_7069c164685e
-rw-r--r-- 1 wwwrun www    23565 2011-07-01 00:00 2011_06_30_u_7069c164685e
-rw-r--r-- 1 wwwrun www   128591 2011-07-02 12:41 2011_07_01_7069c164685e
-rw-r--r-- 1 wwwrun www    22899 2011-07-02 12:41 2011_07_01_u_7069c164685e
-rw-r--r-- 1 wwwrun www    95346 2011-07-02 12:25 2011_07_02_7069c164685e
-rwxrwxrwx 1 wwwrun users     52 2011-06-30 12:22 .htaccess*
-rwxrwxrwx 1 wwwrun users   1697 2011-06-25 15:42 index.html*
arnolde@eq4:/srv/www/vhosts/marketingclips/livesupport/stats/day>

I notice there is only one file today, where there should be 2?

How to I get livezilla to resume reporting?

regards,
Ethan





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users