Jump to content


PHP Fatal error: Call to undefined function mysql_connect() in _lib/object_lib/objects.global.inc.php on line 7914

bugs php fatal error

4 replies to this topic

#1 webmasteratlantis

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 06 September 2019 - 06:43 AM

4 weeks ago i update our LiveZilla from 7.0 to 8.0. it is working for a couple of hours. When I first encounter the issue, the screen was blank then I realized maybe I need to update the php config from 5.6 to 7.1 then it works again for only a couple of hours. I thought 7.1 maybe is not really the solution so change the php config to 5.6 and it works again... only for a couple of hours. I contacted our server and made some fixes. But a couple of hours it is broken again, i check out the php config and sure enough they just change the php config to 7.1. I send a number of tickets to hostgator and to liveZilla support. the only response I get are the issues we're having is not caused by them, meaning not from server's end and not in LiveZilla.

just to save our client I had no choice but to switch the php version from 5.6 to 7.1 or vice versa.

The instruction for updating the liveZilla is so simple, just override all the existing file with updated files, run the /install and that's it. I never encountered issues upon updating our liveZilla. Now for the last time I will take this chance maybe someone ha encountered this and manage to fixed the issue.

our server info:
  • Database client version: libmysql - 5.1.73
  • PHP extension: mysqliPosted Image curlPosted Image mbstringPosted Image
  • PHP version: 7.2.7
error_log:

[05-Sep-2019 00:35:37 America/Chicago] PHP Fatal error: Call to undefined function mysql_connect() in /home2/atlantis/public_html/support/_lib/objects.global.inc.php on line 7914

Hoping for positive feedback. its been 4 weeks so imagine the loss this issue already gave to us.

Thank you so much in advance!

Attached Thumbnails

  • Attached Image: php-parse-error.PNG


#2 Patrick Keil

    Administrator

  • Administrators
  • 3854 posts
  • LocationSingen, Germany

Posted 06 September 2019 - 08:33 AM

Hi,

PHP7 only supports mysqli (note the i) and support for the classic mysql interface has been removed.

If you have configured mysql (without i) extension in LiveZilla, please correct the MySQL configuration manually as described here:

The MySQL authentication has changed. How can I update the LiveZilla MySQL settings?:
https://chat.livezil...-login-changed/

You will need to change gl_db_ext to "mysqli".

Alternatively, run another update and switch from mysql to mysqli on the database configuration page of the wizard.


Hope that helps.


#3 webmasteratlantis

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 06 September 2019 - 08:51 AM

Thank you Admin quick response. please see the current content of my config file.

$_CONFIG['gl_pr_cr'] = 'xxxxxxxxxx';
$_CONFIG['gl_lzid'] = 'xxxxxxxxxx';
$_CONFIG['b64'] = false;

$_CONFIG[0]['gl_db_host'] = 'localhost';
$_CONFIG[0]['gl_db_user'] = 'xxxxxxxxxx';
$_CONFIG[0]['gl_db_ext'] = 'mysqli';
$_CONFIG[0]['gl_db_eng'] = 'MyISAM';
$_CONFIG[0]['gl_db_pass'] = 'xxxxxxxxxx';
$_CONFIG[0]['gl_db_name'] = 'xxxxxxxxxx';
$_CONFIG[0]['gl_db_prefix'] = 'xx_';

I haven't done anything yet. gl_db_ext already set to mysqli should I change it to mysql (remove the 'i' ?)


I just notice on the front page of our livezilla it says MySql (without 'i') but in my config is says Mysqli. is that ok?

Posted Image

#4 Patrick Keil

    Administrator

  • Administrators
  • 3854 posts
  • LocationSingen, Germany

Posted 06 September 2019 - 09:34 AM

Quote

is that ok?
That's fine.

Quote

lready set to mysqli should I change it to mysql (remove the 'i' ?)
No, it must be set to mysqli. I don't understand the problem. Your configuration is fine and with gl_db_ext set to mysqli, it will not use mysql_connect but mysqli_connect.

#5 webmasteratlantis

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 06 September 2019 - 10:00 AM

I don't understand it either :( I can give you an ftp access to our liveZilla if you want. I think that the only way for us to fix our issue. Please give me your email if you are willing please :(





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users