Jump to content


Issues with start chat overlay


4 replies to this topic

#1 Willy

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 10 January 2019 - 09:01 AM

We have two issues with the start chat overlay.

1.
We use Dutch and even though everything required for Dutch for the overlay is set it still shows English. We have translated all strings and set the GUI language in the link generator to "NL-Dutch". Dutch is also the default language for all groups, all other languages removed.

2.
Under routing we have Target Group and Hide Groups checked, Hide all other groups unchecked and several other groups unchecked. We have operators online in all the groups. Still, the overlay doesn't show a selection box after "Department:".

We're on version 8.0.0.6.

Attached Thumbnails

  • Attached Image: start_chat.JPG
  • Attached Image: chat_routing.JPG


#2 Patrick Keil

    Administrator

  • Administrators
  • 3700 posts
  • LocationSingen, Germany

Posted 10 January 2019 - 12:22 PM

Hi,

Quote

We have translated all strings and set the GUI language
Did you translate the server side, too? It's often missed: LiveZilla -> Link Generator -> Server (Visitors)

Quote

Still, the overlay doesn't show a selection box after "Department:".
What about the options to hide the group selection under: LiveZilla -> Link Generator -> Element -> Advanced?

Cheers

#3 Willy

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 10 January 2019 - 01:22 PM

View PostPatrick Keil, on 10 January 2019 - 12:22 PM, said:

Did you translate the server side, too? It's often missed: LiveZilla -> Link Generator -> Server (Visitors)
Yes I did. Added a screenshot to clarify.

View PostPatrick Keil, on 10 January 2019 - 12:22 PM, said:

What about the options to hide the group selection under: LiveZilla -> Link Generator -> Element -> Advanced?
"Hide chat group selection box" is unchecked.

So I noticed that sometimes the selection box is sort of showing but with a messed up layout, see screenshot. It's unclear to me why it sometimes shows but mostly not. I've checked that we have available operators because I think a department is not shown when it has no operators but we have sufficient operators available.

Attached Thumbnails

  • Attached Image: translation.jpg
  • Attached Image: group_selection.jpg


#4 Patrick Keil

    Administrator

  • Administrators
  • 3700 posts
  • LocationSingen, Germany

Posted 10 January 2019 - 02:26 PM

Quote

Yes I did. Added a screenshot to clarify.
The screenshot doesn't show the language list on the right side so I need to ask: did you add "dutch" as a new language set or did you just translate the english language set?

Quote

but with a messed up layout,
This must be a CSS issue then, your websites default css uses general rules that apply to all select elements.

#5 Willy

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 10 January 2019 - 02:34 PM

View PostPatrick Keil, on 10 January 2019 - 02:26 PM, said:

The screenshot doesn't show the language list on the right side so I need to ask: did you add "dutch" as a new language set or did you just translate the english language set?
We added Dutch to all groups and removed all other languages. In the editor we select Dutch first before editing anything. Some of the translations for the overlay were already translated by default (f.e. the explanation text).

We've set Dutch as default language under "Server configuration -> Translation".


Turns out that all problems with the selection box are CSS related, sorry about that.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users