Jump to content

LiveZilla not working with SSL

  • You cannot reply to this topic
No replies to this topic

#1 0x6c23


  • Members
  • Pip
  • 1 posts

Posted 03 April 2018 - 10:13 AM

I am running a CentOS server with NGINX and PHP-FPM, everything runs with SSL. I also use cloudflare.

I tried installing LiveZilla to a subfolder called livezilla/. Upon visiting /livezilla in my browser, I see this:


There should be a big blue button in the middle stating something along the lines of Install Now, which is not the case here. I also get errors in the browser console:

(index):126 Uncaught ReferenceError: install_goto is not defined
	at HTMLTableRowElement.onclick ((index):126)
onclick @ (index):126
index.js:66 Uncaught ReferenceError: lz_update_mode is not defined
	at HTMLDocument.<anonymous> (index.js:66)
	at j (jquery-2.1.0.min.js:2)
	at Object.add [as done] (jquery-2.1.0.min.js:2)
	at o.fn.init.o.fn.ready (jquery-2.1.0.min.js:2)
	at index.js:58

I tried to open the website with http:// instead of https:// and it initially redirected me back to https://, but after adding a Page Rule in cloudflare where I disabled SSL, RocketLauncher and Security it worked. I installed LiveZilla and everything seemed to work, the floating chat button appears on my website and I can even use the data pass-through to pass usernames to the operator console.
BUT when I try to send a message in the chat, it doesn't work. It says connecting... forever and the server never receives the message.
What I tried:
  • Reinstalling livezilla (New subfolder, new database)
  • All combinations of the following Server settings: Server refuses all connections without encryption (HTTP), Use HTTPS? -> Always, Detect automatically
  • Creating chat buttons for http and https.
So what could be the culprit here? I really don't know why LiveZilla does not load with https. Any nginx configuration maybe?

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users