Jump to content


Ticketsystem - external URL


5 replies to this topic

#1 tberen

    Member

  • Members
  • PipPip
  • 21 posts

Posted 07 August 2017 - 07:50 AM

We are using external Link for Leave Message function and redirect the customer to a landing page in our service center. In Old livezilla (5.0.4.2 or something) with text link the customer gets directly redirected. In this current version, the customer sees a chat window where he can enter his personal information, such as name, phone, mail, and so on. But he can't start a chat of course not, cause it's offline. When he clicks on Leave a message button he will redirected to the landing page.

When the chat is offline and a external url is used, it does make no sense to ask the customer for his personal data.

btw: the Option "Open in external chat window" has no effect.

Currently we are using livezilla 7.0.6.0

kind regards Thomas

#2 Patrick Keil

    Administrator

  • Administrators
  • 3631 posts
  • LocationSingen, Germany

Posted 07 August 2017 - 09:06 AM

Hi Thomas,

Thanks for bringing this to our attention.

We will try to fix that for the next update.

#3 mgts

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 08 July 2018 - 04:19 AM

Hello, sorry to jump in on this, it has been almost a year and this problem hasn't been resolved. Or was it ? In order to move to the specific modified External Ticket System link, the user has to open the main chat window and click on Leave Message in order for the external link to open, but it leaves the main chat window open.

On the old 6.0.x.x Livezila versions when using an external link for the Ticket System it would automatically close original clicked link ( chat text link > chat window ) and open another window or tab with the specific URL given. Please resolve this issue if possible, still present on 7.1.0.3. Or is there another reason for not changing the behavior as it was on older Livezilla versions ?

Thank you for reading.

#4 Patrick Keil

    Administrator

  • Administrators
  • 3631 posts
  • LocationSingen, Germany

Posted 09 July 2018 - 01:57 PM

Hi,

Problem should be fixed and I can't reproduce the issue any longer.

Feel free to provide more detailed instructions on how to reproduce the problem.

Don't forget to include your chat button configuration.

Thanks.

#5 mgts

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 12 July 2018 - 01:31 PM

Hello and thank you for responding. The problem seems to happen on the "Text Link" option.

Once the link is clicked the main chat window appears where it says:

Sorry - we are not available at the moment. Please try again later.

and below there is the "Leave Message" button which by clicking would open a new window/tab with the link specified in Server Configuration > Tickets.

The "Chat Overlay Widget V2" works, I mean it redirects if user clicks on the 'balloon' .

Here are the options I've used for the Text Link button:

VISITOR MONITORING
Posted Image

Posted Image



Text Link

Posted Image

Posted Image

Posted Image

Posted Image


SERVER CONFIG ( problem persists if "External Window" is checked or not )
Posted Image

Generated Code (unlisted expires in 2 weeks from now): https://pastebin.com/7CmwPWJp

Please let me know if there is a way for the Text Link to work, (a workaround at least), if not, I will try to use the Widget though on some parts of the site I'm building I will not be able to use the Widget.

Thank you very much for your interest in helping us/me out !

#6 Patrick Keil

    Administrator

  • Administrators
  • 3631 posts
  • LocationSingen, Germany

Posted 12 July 2018 - 02:25 PM

Hi,

Thanks for the details, highly appreciated.

I can reproduce the problem. Unfortunately, there's no workaround for this, the pop chat window does not autoforward.

We will add this to our list but I can't provide a quick solution.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users