Jump to content


Default Language for Knowledgebase


8 replies to this topic

#1 Asb-nn

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 14 May 2018 - 09:05 AM

Hello,

What we are trying to do is to make /livezilla/knowledgebase.php showing the content in any other language but english. However, whatever we try, if somebody clicks on the link , it shows the english language content. The only way we accomplished to show other language contents is by adding something like "knowledgebase.php?ptl=sr" .

Would you please assist, as we saw some other websites using livezilla having this working?

Kind regards,
Nemanja

#2 Patrick Keil

    Administrator

  • Administrators
  • 3504 posts
  • LocationSingen, Germany

Posted 14 May 2018 - 09:30 AM

Hi Nemenja,

Did you define languages for each of your Knowledge Base entries?

Knowledge Base -> Entry -> Settings Tab -> Language

Hope that helps.

#3 Asb-nn

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 14 May 2018 - 02:32 PM

Hi Patrick,

Yes I did. And when I add ?ptl=languagecode after knowledgebase.php then it gives the page in that language. However, if I dont add ?ptl=whatever then it shows only ENGLISH.

#4 Patrick Keil

    Administrator

  • Administrators
  • 3504 posts
  • LocationSingen, Germany

Posted 15 May 2018 - 06:55 AM

Yes, English is your fallback.

When no language is defined, it will show english entries and entries with no language set.


Sorry, that's not correct.

The visitors browser language is the fallback language.

#5 Asb-nn

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 15 May 2018 - 09:35 AM

"when no language is defined" - you mean if there is no "?ptl=languagecode" after knowledgebase.php ?

Is there a way to make fallback language some other language ? I have seen some livezilla installations showing German or Portugese when there is no "?ptl=languagecode" after knowledgebase.php .

#6 Patrick Keil

    Administrator

  • Administrators
  • 3504 posts
  • LocationSingen, Germany

Posted 15 May 2018 - 10:22 AM

Quote

"when no language is defined" - you mean if there is no "?ptl=languagecode" after knowledgebase.php ?
Exactly.

Quote

Is there a way to make fallback language some other language ?
Unfortunately, no. Other installation may have no english entries.

#7 Asb-nn

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 15 May 2018 - 10:59 AM

Hi. Thanks again. But I must ask....

If I change gl_default_language to "DE" (no articles in German language), I do get the german page if I choose knowledgebase.php witout "?plt"

On the other side, if i change gl_default_language to any other language (with or without entries in that language), it will give only english.

#8 Patrick Keil

    Administrator

  • Administrators
  • 3504 posts
  • LocationSingen, Germany

Posted 15 May 2018 - 12:53 PM

Yes, you can change your default language in the server configuration under Server Configuration -> Translation.

If you do that, please make sure to provide a translation for the language set.

Translations can be added under:

Translation Editor -> Server

I think that's what makes the difference between DE and the other languages you tried.

#9 Asb-nn

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 16 May 2018 - 07:47 AM

Hi Patrick,

I'm afraid, this is not the case, as I have implemented everything you mentioned. Let me visualise it (screenshots next to each step ):

1. Server Configuration -> Translation -> Default Language -> Serbian (photo: http://api.allsecure...livezilla/1.png )
2. Translation Editor -> Server -> Serbian (photo http://api.allsecure...livezilla/2.png )
3. Knowledge Base -> Article / Folder Items -> Edit -> Settings -> Language -> Serbian (photo http://api.allsecure...livezilla/3.png )

4. When URL doesnt contain ?ptl the page shows ENGLISH as the default language (all elements in english) and no articles present (photo http://api.allsecure...livezilla/4.png )

5. When URL contains ?ptl the page shows SERBIAN language for all elements and articles in Serbian are presented (photo http://api.allsecure...livezilla/5.png ).

Needless to say, I tried this in other languages, but its not working.

Would you say this is the general bug or ?

Kind regards,
Nemanja





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users