Jump to content


Error Codes while Trying LZ Analytics Beta


1 reply to this topic

#1 DanielR

    Advanced Member

  • Members
  • PipPipPip
  • 48 posts

Posted 12 May 2018 - 06:38 AM

Dear LZ Team,

We tried to use Analytics beta and notices ome errors appearing afterwards:

PHP Log:
12.05.18 08:30:37 ERR# 8 Use of undefined constant console - assumed 'console' /var/www/livezilla_server_7.1.0.0/livezilla/_lib/objects.analytics.inc.php IN LINE 882
12.05.18 08:30:37 ERR# 2 log() expects parameter 1 to be double, string given /var/www/livezilla_server_7.1.0.0/livezilla/_lib/objects.analytics.inc.php IN LINE 882

SQL Log:
12.05.18 08:30:37 - 1054: Unknown column 'hour' in 'field list'
SQL: SELECT CONCAT(`year`, '-', LPAD(`month`, 2, '0'), '-', LPAD(`day`, 2, '0'), '-', LPAD(`hour`, 2, '0')) as `dateString`, IFNULL(SUM(`amount`),0) FROM `lz_stats_aggs_goals` WHERE CAST(CONCAT(`year`, LPAD(`month`, 2, '0'), LPAD(`day`, 2, '0')) AS UNSIGNED) BETWEEN CAST('20180511' AS UNSIGNED) AND CAST('20180511' AS UNSIGNED) GROUP BY `dateString` ORDER BY `dateString`;
12.05.18 08:30:37 - 1054: Unknown column 'hour' in 'field list'
SQL: SELECT CONCAT(`year`, '-', LPAD(`month`, 2, '0'), '-', LPAD(`day`, 2, '0'), '-', LPAD(`hour`, 2, '0')) as `dateString`, IFNULL(SUM(`amount`),0) FROM `lz_stats_aggs_feedbacks` WHERE CAST(CONCAT(`year`, LPAD(`month`, 2, '0'), LPAD(`day`, 2, '0')) AS UNSIGNED) BETWEEN CAST('20180511' AS UNSIGNED) AND CAST('20180511' AS UNSIGNED) AND `group_id`>'' GROUP BY `dateString` ORDER BY `dateString`;
12.05.18 08:30:37 - 1054: Unknown column 'hour' in 'field list'
SQL: SELECT CONCAT(`year`, '-', LPAD(`month`, 2, '0'), '-', LPAD(`day`, 2, '0'), '-', LPAD(`hour`, 2, '0')) as `dateString`, IFNULL( (SUM(`ca`) + SUM(`cb`) + SUM(`cc`) + SUM(`cd`) ) /(SUM(`amount`) * 4),0), SUM(`amount`) FROM `lz_stats_aggs_feedbacks` WHERE CAST(CONCAT(`year`, LPAD(`month`, 2, '0'), LPAD(`day`, 2, '0')) AS UNSIGNED) BETWEEN CAST('20180511' AS UNSIGNED) AND CAST('20180511' AS UNSIGNED) AND `group_id`>'' GROUP BY `dateString` ORDER BY `dateString`;

Thanks,
Daniel

#2 Patrick Keil

    Administrator

  • Administrators
  • 3504 posts
  • LocationSingen, Germany

Posted 14 May 2018 - 08:47 AM

Hi Daniel,

Thanks for bringing this to our attention.

We know about these errors and they should be gone with our tomorrows update 7.1.0.1.

Cheers.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users