Jump to content


Disabled wrapper: allow_url_fopen


7 replies to this topic

#1 Corobori

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 23 April 2018 - 08:50 PM

I am trying to install LiveZilla on a Windows Server. This is the error I am getting. Any idea what I should do ?

Posted Image

#2 NEO.pl

    Advanced Member

  • Members
  • PipPipPip
  • 53 posts

Posted 24 April 2018 - 02:48 AM

Isn't error message self explanatory?

Aside from that, it's really bad that LZ requires that settings enabled. There's cURL for that.

#3 Corobori

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 24 April 2018 - 07:38 PM

View PostNEO.pl, on 24 April 2018 - 02:48 AM, said:

Isn't error message self explanatory?
I guess if you're working with PHP it is but I am not. That said I tried adding a php.ini in the root folder of LZ where I wrote allow_url_fopen = On it didn't work then I tried allow_url_fopen "1" it didn't work neither.

Is this something I can do or should I contact my hosting company ?

#4 Patrick Keil

    Administrator

  • Administrators
  • 3616 posts
  • LocationSingen, Germany

Posted 25 April 2018 - 11:48 AM

Quote

There's cURL for that.
Good point, we will consider a switch.

Quote

Is this something I can do or should I contact my hosting company ?
Yes, absolutely.

Cheers.

#5 Corobori

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 02 May 2018 - 02:16 PM

View PostPatrick Keil, on 25 April 2018 - 11:48 AM, said:

Yes, absolutely.

Your answer is for "something I can do" or for "should I contact my hosting company" ?

That said if you search in Google for "disabled wrapper: allow_url_fopenLiveZilla requires allow_url_fopen" you'll find pages of sites having the same issue. Not sure about you but I would consider it as a serious issue so many people not being able to use my service. Perhaps the message is "self explanatory" but how many of those site's owner are aware of it ?

Posted Image

#6 Patrick Keil

    Administrator

  • Administrators
  • 3616 posts
  • LocationSingen, Germany

Posted 03 May 2018 - 07:09 AM

Quote

Your answer is for "something I can do" or for "should I contact my hosting company" ?

Sorry, I recommend to get in touch with your webhosting company.

Quote

consider it as a serious issue

It's a limitation of your webserver and LiveZilla informs you about it. The technical person in charge of the webserver should be able to solve it in a minute.

#7 Corobori

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 03 May 2018 - 04:37 PM

View PostPatrick Keil, on 03 May 2018 - 07:09 AM, said:

Sorry, I recommend to get in touch with your webhosting company.

I am doomed ! This my webhosting company's answer: Thank you for contacting Newtek Technology Solutions. Due to new security in place we will not be able to allow "allow_url_fopen" to be enabled

View PostPatrick Keil, on 03 May 2018 - 07:09 AM, said:

It's a limitation of your webserver and LiveZilla informs you about it

True, it is a limitation of my server but doesn't it bother you that tens of other websites are having the same issue ? See here

#8 Patrick Keil

    Administrator

  • Administrators
  • 3616 posts
  • LocationSingen, Germany

Posted 04 May 2018 - 07:42 AM

We usually recommend a dedicated server that gives you full control anyway.

And It's actually not a big issue. I guess most of the users affected by this don't even notice the side effects. Core functions are still available.

As neo suggested, cURL could be a good replacement but I think that most hosts that deactivate allow_url_fopen will also block cURL.

Cheers.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users