Jump to content


search in tickets does not find open tickets


10 replies to this topic

#1 capella

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 11 April 2018 - 08:39 AM

I wonder if this is a bug or a feature?

If I put an email address in the search field of the ticket search, I get back emails from every category except from the open tickets.

It would be much better, if the search would find the open tickets too, so that I can merge them with old tickets.

#2 Patrick Keil

    Administrator

  • Administrators
  • 3669 posts
  • LocationSingen, Germany

Posted 11 April 2018 - 01:04 PM

Definitely not a feature but I can't reproduce a bug.

I get tickets from all categories including "open".

#3 capella

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 11 April 2018 - 03:03 PM

I tested again and no chance. I never get open tickets, independend of what I am searching for.

LiveZilla Server-Version: 7.0.9.5

Just to be clear, I am putting my search terms in this input field:

Attached Image: Bildschirmfoto 2018-04-11 um 16.56.00.png

What can I do to find out more?

#4 Patrick Keil

    Administrator

  • Administrators
  • 3669 posts
  • LocationSingen, Germany

Posted 12 April 2018 - 06:40 AM

Hi,

How's your Tickets "Filter" setup? All boxes checked?

What category did you select before activating the search field?

What's your search query?

Thanks.

#5 capella

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 12 April 2018 - 07:46 AM

View PostPatrick Keil, on 12 April 2018 - 06:40 AM, said:

How's your Tickets "Filter" setup? All boxes checked?

Yes, all checked.

View PostPatrick Keil, on 12 April 2018 - 06:40 AM, said:

What category did you select before activating the search field?

The result is the same, no matter which category was selected before I start the search.

View PostPatrick Keil, on 12 April 2018 - 06:40 AM, said:

What's your search query?

I tried an email address and a string from the mail body, no difference either.

#6 capella

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 20 April 2018 - 09:32 AM

Today I found some time to investigate more.
The bug is more tricky than I thought.

The condition when a ticket was found or not is this:
Only if a record for the ticket is present in lz_ticket_editors the ticket will be part of the result set.

For what ever reason an newly received ticket gets no record in lz_ticket_editors. Once I open the ticket and hit the button OK, the record in lz_ticket_editors will appear and all is fine.

Guesswork: having no record in lz_ticket_editors creates NULL values in the query result, which might confuse the logic. Especially the filed status might be a problem.

I think the cleanest solution would be to always create a record in lz_ticket_editors for every arriving ticket.

#7 Patrick Keil

    Administrator

  • Administrators
  • 3669 posts
  • LocationSingen, Germany

Posted 20 April 2018 - 12:20 PM

Thanks, I will check again on monday.

#8 Patrick Keil

    Administrator

  • Administrators
  • 3669 posts
  • LocationSingen, Germany

Posted 23 April 2018 - 07:16 AM

Hey,

How did you create those tickets? Via API?

I tried a few tickets and the editor row is always being created.

Any SQL error logs?

Thanks.

#9 capella

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 23 April 2018 - 07:53 AM

The tickets have been created via email (IMAP).

No SQL error in the log, that could be related to this problem.

I can confirm that the issue depends on the channel where the ticket is coming from:
Manually created tickets are fine.
Tickets from our Website are having the same problem.

#10 Patrick Keil

    Administrator

  • Administrators
  • 3669 posts
  • LocationSingen, Germany

Posted 23 April 2018 - 10:41 AM

Thanks for your help!

We were able to reproduce and fix this issue.

#11 capella

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 23 April 2018 - 10:44 AM

Good news, thanks!





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users