Jump to content


New Ticket: Ability to insert from knowledgebase

tickets knowledgebase

4 replies to this topic

#1 lzst3rer

    Advanced Member

  • Members
  • PipPipPip
  • 98 posts

Posted 25 October 2017 - 02:01 AM

There are 2 issues I found while testing LiveZilla's ticketing system:

1) When creating a new ticket from operator interface, one can enter details but cannot load entries from Knowledgebase.
A feature that would allow this is very useful because there are a lot of cases where we e-mail a customer information that was requested over the phone/Facebook, and that information is so common that it has its own Knowledgebase entry.

This way, we have to create a blank ticket and then open that ticket to send necessary information.


2) E-mail replies keep prepending the subject template to e-mails ad-infinitum. So, we end up with subjects looking like this:

Re: [39B25FEFD4E6] Re: [39B25FEFD4E6] My Ticket Title

I know that this is what e-mail threads may look like in ancient e-mail clients but is there a way stop this from happening with LiveZilla? I know it's possible but I'm asking if it could/should be done since it would be a much cleaner way to generate and store e-mail subjects.

Thank you for reading.

#2 Patrick Keil

    Administrator

  • Administrators
  • 3506 posts
  • LocationSingen, Germany

Posted 25 October 2017 - 08:04 AM

Hi,

1.) The first message of a ticket represents the customer request (=question). The second message represents your reply (=answer) which includes the information from the knowledge base. If you would start with the answer, you would have no question and the ticket will be hard to understand retrospectively.

2.) I haven't seen this before. LiveZilla only adds the [HASH] when it's not existing in the subjects. Are you sure that this isn't caused by the e-mail client?

#3 lzst3rer

    Advanced Member

  • Members
  • PipPipPip
  • 98 posts

Posted 25 October 2017 - 09:12 AM

1) That makes sense. Then:
a.) Will the customer ever see the initial ticket if it's created from operator side?
b.) It still makes sense to have uniform requests from customers instead of entering them manually every time. For example, we might have an offer running and there are interested parties that call up -- we should be able to have some way to re-use previously entered requests.

2) I have only been testing LiveZilla > E-mail, not the other way around. I don't know how the e-mail client (receiver) could modify what LiveZilla (sender) is creating. The way to re-produce it is:
a.) Create new ticket
b.) Reply to the new ticket a few times
c.) Check e-mail headers in your client ("Show Original Messge" in Gmail)

Let me know if you'd like me to send e-mail headers in private for your analysis.

Thanks.

#4 Patrick Keil

    Administrator

  • Administrators
  • 3506 posts
  • LocationSingen, Germany

Posted 25 October 2017 - 10:32 AM

Hi,

1.)

a.) No it's the request. You have confirmed the receipt in your phone call. Customer only receives the reply.
b.) There's no such a function but you can use the API if you need to create tickets from batch.

2.)

I've done that, sent 3 messages into each direction but the subject remains purely "Subject: Re: [72D67B509805] - Your message".

However, I think we found the problem. You have added the %subject% placeholder to your email template's (operator reply) subject line. It turned out that it add's the subject of the last email instead of adding the subject of the ticket. That will create the loop described. We will fix that for the next update.

#5 lzst3rer

    Advanced Member

  • Members
  • PipPipPip
  • 98 posts

Posted 10 November 2017 - 08:31 PM

I see that #2 was addressed in version 7.0.8.6 but I'm still seeing this problem. However, when I reply from LiveZilla, it prepends "Re: [ABCXZYSDY]" to the subject. I am using %subject% in the template.

Is there any way to force a cache clear or check that this piece of code has been implemented?

I had MEMCACHED caching enabled and I now disabled caching completely but I don't know if there's a dir I need to empty or something.

Thanks!





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users