Jump to content


Text Link Chat does not work if pass thru is activated

chat textlink passthru

11 replies to this topic

#1 DanielR

    Advanced Member

  • Members
  • PipPipPip
  • 48 posts

Posted 27 July 2017 - 08:30 AM

Dear LZ Team,

It appears that if we create a Text Link chat and activate Pass Thru fields that the chat doesn't work. Means we click on the link but nothing happens. If we then deactivate pass thru everything works as expected.

Is this intended?

Thanks,
Daniel

#2 Patrick Keil

    Administrator

  • Administrators
  • 3510 posts
  • LocationSingen, Germany

Posted 01 August 2017 - 06:12 AM

Hi Daniel,

It's not sufficient to activate the pass-thru function, you actually need to replace the placeholders added to the code. If you don't replace or if you don't do this correctly, the chat button may not work properly.

https://www.livezill...id=passthrudata

#3 Jonathan

    Member

  • Members
  • PipPip
  • 14 posts

Posted 25 September 2017 - 01:33 PM

Hi Patrick,

I can confirm that Daniel is right. I tried to make a text link. And the preview and live only works when deactivating the pass-thru function or when we remove <!--replace_me_with_b64_encoded_Question--> in the question field.

Can you re-check that?

Thanks,
Jonathan

#4 Patrick Keil

    Administrator

  • Administrators
  • 3510 posts
  • LocationSingen, Germany

Posted 25 September 2017 - 01:39 PM

Hi Jonathan,

Thanks for the clarification. I can confirm a problem with data pass thru on Text Link, we will provide a fix with LiveZilla 7.0.8.0.

Thanks for your patience.

#5 Jonathan

    Member

  • Members
  • PipPip
  • 14 posts

Posted 26 September 2017 - 09:51 AM

Hi,

looking forward to the update.

Additional info: same happens if I choose "Alle anderen Gruppen ausblenden" in the textlink configuration (Routing>Gruppe).

#6 Patrick Keil

    Administrator

  • Administrators
  • 3510 posts
  • LocationSingen, Germany

Posted 26 September 2017 - 11:04 AM

Thanks for the info!

#7 Jonathan

    Member

  • Members
  • PipPip
  • 14 posts

Posted 05 October 2017 - 08:59 AM

View PostPatrick Keil, on 25 September 2017 - 01:39 PM, said:

Hi Jonathan,

Thanks for the clarification. I can confirm a problem with data pass thru on Text Link, we will provide a fix with LiveZilla 7.0.8.0.

Thanks for your patience.

I just installed the update 7.0.8.1 on my test environment. Am I right that you disabled the pass-thru for text links? Is that how you "provide a fix"?

#8 Patrick Keil

    Administrator

  • Administrators
  • 3510 posts
  • LocationSingen, Germany

Posted 05 October 2017 - 09:29 AM

There was a complete redesign of how pass-thru data is used. Text links are missing yet but will come back in 7.0.8.2.

Thanks for your patience.

#9 Jonathan

    Member

  • Members
  • PipPip
  • 14 posts

Posted 09 October 2017 - 09:14 AM

Thanks for the fast response. I updated to 7.0.8.2 and activated pass-throu for my textlink and end up with this link on my page:
<!-- livezilla.net PLACE WHERE YOU WANT TO SHOW TEXT LINK -->
<a class="lz_text_link" href="javascript:void(window.open('http://beta2.gf-werbeartikel.de/livezilla/chat.php?v=2&amp;group=support&amp;hg=Pw__&amp;ptn=Jonathan &amp;pte=j.stahl@test.de&amp;ptc=GF&amp;ptq=Testfrage&amp;ptp=09365 888830&amp;hfc=MQ__&amp;hfk=MQ__','','width=400,height=600,left=0,top=0,resizable=yes,menubar=no,location=no,status=yes,scrollbars=yes'))" alt="LiveZilla Live Chat Software" data-text-online="Fragen zum Produkt" data-text-offline="Fragen zum Produkt" data-css-online="" data-css-offline="" data-online-only="0">Fragen zum Produkt</a>
<!-- livezilla.net PLACE WHERE YOU WANT TO SHOW TEXT LINK -->

Problem: In the chat window no data is filled. All fields are empty.

Can you help me?

#10 Patrick Keil

    Administrator

  • Administrators
  • 3510 posts
  • LocationSingen, Germany

Posted 09 October 2017 - 01:33 PM

Hi Jonathan,

Thanks for bringing this to our attention.

I did some tests and I can confirm this issue. It works with visitor monitoring activated while the pure text link does not inject the data.

We will come up with another bug fix asap (should be 7.0.8.4).

I am really sorry for the inconvenience caused.

#11 Jonathan

    Member

  • Members
  • PipPip
  • 14 posts

Posted 11 October 2017 - 06:29 AM

Thanks for the information. I always disable visitor monitoring for the textlink, because I have it activated with my overlay widget.

Is this necessary or doesn't affect this the performance/robustness of livezilla?

#12 Patrick Keil

    Administrator

  • Administrators
  • 3510 posts
  • LocationSingen, Germany

Posted 11 October 2017 - 07:37 AM

Hi Jonathan,

please note that this is a bug. The Text Link parameters are supposed to work with or without visitor monitoring. A fix will be included in 7.0.8.4.

The visitor monitoring requires more resources.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users