Jump to content


Chatbot API Program-O Bot

chatbot

3 replies to this topic

#1 nicks12

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 12 July 2017 - 12:57 PM

Hi there!

I've installed LiveZilla and i'm testing with the chatbot api. On Livezilla.com I've noticed the Program-O Bot API. So I've installed Program-O Bot on my server and I've copied the API code from the LiveZilla website to a PHP file on my server. I've inserted the URL to this PHP file in the 'Bot account' on my LiveZilla server.

When I set-up a test conversation with 'my bot' it only responds that it can't find any answers. In the error log I've noticed a invalid response due to the VisitorId:

[color=#333333][font=Arial, Helvetica,]IN LINE 0 12.07.17 14:52:08 213.124.91.170 ERR# 129 Error connecting USER API, invalid response: [url="https://www."]https://www.[/url][URL].nl/livezilla/chatbot/chatbot.php ( Notice: Undefined property: stdClass::$VisitorId in /home/vhosting/w/vhost0057496/domains/[URL]/htdocs/www/livezilla/chatbot/chatbot.php on line 8 {"ResponseTo":"","Id":7135977,"SearchKB":false,"Value":"Question?"}) IN LINE 0[/font][/color]

Removing the VisitorId from the URL in chatbot.php has resulted in the expected answers, but then it is not possible to have 'normal' conversation because the bot doesn't remember previous questions/answers. (Example: the bot asks a question which I answer with yes/no, it then responds uknowingly.)
Anybody has any idea how I can fix this so that a 'normal' conersation is possible?

Thanks in advance!

Nick

#2 Patrick Keil

    Administrator

  • Administrators
  • 3087 posts
  • LocationSingen, Germany

Posted 13 July 2017 - 06:55 AM

Hi Nick,

I tested the chatobot example and I don't have problems with the VisitorId.

Which LiveZilla version do you use?

#3 Patrick Keil

    Administrator

  • Administrators
  • 3087 posts
  • LocationSingen, Germany

Posted 13 July 2017 - 07:02 AM

Nevermind, the VisitorId has not been implemented yet. It will be added in the release 7.0.6.0 coming next week.

I'm sorry for the inconvenience caused.

#4 nicks12

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 13 July 2017 - 08:26 AM

Oké then I'll wait for one more week :)

Thank you!





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users